Ways to connect BMW E-SYS to ICOM or ENET cable

BMW E-SYS connection tips and guides for all those with ICOM cables or ENET Ethernet interface…

BMW ICOM settings for E-SYS:

Step 1: Run ISTA-D and check ICOM IP (occasionally, slightly different of Windows IP 169.254.55.70)
Possibly iToolRadar will do exactly the same

BMW-E-SYS-1

Step 2: Run Easyconnect
Form: REMOTE
IP: 169.254.55.83 (edit file ip_dv.txt and add IP)
MODE: OBD_ab625
ICOM Lock
Check

BMW-E-SYS-2

Step three: Run E-sys

BMW-E-SYS-3 BMW-E-SYS-4

Connect through ICOM cable/Ethernet interface (tcp://169.254.55.83:50160)

Esys Connection Questions & Answers:

Question & Answer 1:
Q: I used the ISTAD method to obtain the IP address. However, I was not able to get EasyConnect utility to work. Fortunately, I was still able to get ESys working and coded the RDC_Safety and blinker # back to what it was before.
A: EasyConnect just to displays IP. You can use ZGW to ID as well as iToolRadar to lock.
Also, trimmed data has no affect on connection. Using the incorrect launcher chassis, target & interface, or neither external charger or running engine to provide power to certain modules, can result in the ECU_ETHERNET map error.

Question & Answer two:
Q: I connected via ICOM/Ethernet not URL.
As for the connection issue, I’m not sure what it was but I was able to to get it sorted out.
A: URL is used for flash programming, but you will use VIN for ENET and ICOM/ENET for ICOM to code.

Question & Answer 3:
Q: Why is url for flashing ?
Can i also take ICOM/ENET for flashing, with a icom clone ?
A: Actually only ZGW must be flash programmed via IP.
ENET can be used with E-sys or ISTA-P to flash.
ICOM (including clone) can be used with E-sys, ISTA-P, or ISTA+.

Question & Answer four:
Q: Which settings i must choose for flashing in e-sys (URL or ICOM/ENET) ?
A: I believe it is still URL, but you must use DHCP (either software or router).

Question & Answer 5:
Q: I did exactly as mentioned to connect ICOM to OBDII and to my computer, but then when I get to connect using ESys, I got the following error message:
“Connection check failed. Gateway/ECU are not correctly connected or not responding. However Function using ODX-Data can be used. [G188]”
A: With ICOM, you connect by means of ICOM. You will need to lock IP with program like EasyConnect or Itool Radar
With ENET, you connect through VIN.
You connect by means of gateway URL if flashing. That error message occurs when you have incorrect IP.

Question & Answer 6:
Q: For ICOM, I was using ITool Radar to lock the IP, then in ESys, I used the IP found in ITool Radar to connect. Am I doing the right thing? Or do I still need to use ICOM ISTA to get the IP address??
And with ENet, after plugging in everything, my computer failed to recognize any connection from the Ethernet port. What I mean is that, there wasn’t even a flashing light on the port that indicates my computer is connected to something, not normal, right?
A: For ICOM, you do not need to separately use ISTA+; that is just another way to discover IP.
With ENET, you should get fallback IP (169.x.x.x)

Question & Answer 7:
Q: So if I don’t need ISAT+ to get the IP, then any clue why I still get that error on ESys after I press connect? Seems like I am getting the proper IP address off ITool Radar… any chance that my car computer is not responding?
And with ENET, it is not getting any fallback coz my computer don’t even know it is plugged in… no steady nor blinking lights on the port…
Some others suggested that my car computer could be in some kind of safe/protection mode that it blocks external connection… is there such thing?
A: With ICOM, you can certainly try with ISTA+ to see if you get a distinct IP to lock with Itool Radar. For ICOM A2, are you selecting 4th interface form and putting in the identical IP?

For ENET, are you selecting 5th option (VIN)? Are you getting anything populated?
Make sure motor is running if car is not on a Charger.
Third party Security Suites (Antivirus / Firewall / etc) are disabled
LAN Adapter is set for DHCP and not using a Static IP.
The Target Connection Window should not be blank (It should show multiple target connections for different chassis’)

Posted in BMW ICOM and tagged , , , , , , , , , , .

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>